Opened 5 years ago

Last modified 5 years ago

#3 new defect

Cocoa application is broken on the trunk for OSX 10.9.5 at r16755

Reported by: tfb Owned by:
Priority: normal Milestone:
Version: Keywords:
Cc:

Description

I am on a Mac running 10.9.5 with (as far as I can tell) the current Xcode and everything for it. This is obviously a slightly old platform now.

$ uname -a
Darwin kingston.local 13.4.0 Darwin Kernel Version 13.4.0: Mon Jan 11 18:17:34 PST 2016; root:xnu-2422.115.15~1/RELEASE_X86_64 x86_64

I checked out the trunk:

$ svn co http://svn.clozure.com/publicsvn/openmcl/trunk/darwinx86/ccl
[...]

Checked out revision 16755.

Then

$ ./ccl/dx86cl64 -n
Welcome to Clozure Common Lisp Version 1.12-dev-r16752  (DarwinX8664)!
[...]

? (require :cocoa-application)
[...]
Saving application to /private/var/tmp/ccl/Clozure CL64.app/

And now:

$ open ccl/Clozure\ CL64.app
The application cannot be opened because it has an incorrect executable format.

This may be because my OSX is just too old: I am planning to upgrade at some point soon. If this is the case, I'll just move to a release version for now.

Change History (1)

comment:1 Changed 5 years ago by tfb

  • Summary changed from Cocoa application is broken on the tunk for OSX 10.9.5 at r16755 to Cocoa application is broken on the trunk for OSX 10.9.5 at r16755
Note: See TracTickets for help on using tickets.