Changes between Version 20 and Version 21 of WindowsNotes


Ignore:
Timestamp:
Aug 5, 2011, 8:40:52 PM (9 years ago)
Author:
rme
Comment:

--

Legend:

Unmodified
Added
Removed
Modified
  • WindowsNotes

    v20 v21  
    3535
    36361) get a subversion (svn) client for Windows.  There are several
    37 choices available; the "certified binaries" available at
    38 
    39 http://subversion.tigris.org/getting.html#windows
    40 
    41 should work well.
     37choices available; http://subversion.apache.org/packages.html#windows
     38lists a number of them.  SlikSVN has worked well for me (rme).
    4239
    4340If you're not comfortable with the Windows command-line, you may
     
    6764
    6865{{{
    69 shell> svn co http://svn.clozure.com/publicsvn/openmcl/release/1.3/windows/ccl
     66shell> svn co http://svn.clozure.com/publicsvn/openmcl/release/1.7/windows/ccl
    7067}}}
    7168
     
    210207configured to use Unix-style line-termination.
    211208
     209Unfortunately, the compiler situation on Cygwin has changed around a bit,
     210so this makes matters somewhat complicated.
     211
     212=== Trunk and Current Cygwin ===
     213
     214Go to http://cygwin.com and download the setup.exe program.  Install the following
     215packages:
     216 * make
     217 * m4
     218
     219If you want to build the 32-bit Windows lisp kernel, also install:
     220 * mingw64-i686-binutils
     221 * mingw64-i686-gcc-core
     222 * mingw64-i686-headers
     223 * mingw64-i686-pthreads
     224 * mingw64-i686-runtime
     225
     226If you want to build the 64-bit Windows lisp kernel, also install:
     227 * mingw64-x86_64-binutils
     228 * mingw64-x86_64-gcc-core
     229 * mingw64-x86_64-headers
     230 * mingw64-x86_64-pthreads
     231 * mingw64-x86_64-runtime
     232
     233Accept the dependencies (a handful of libraries) that the installation
     234tool adds.  Note that you can install all of these packages if you want
     235to build both 32- and 64-bit lisp kernels.
     236
     237=== Older Cygwin (used in ccl 1.7 and earlier) ===
    212238For both the win32 and win64 platforms, it's necessary to install the following Cygwin
    213239packages (if you notice any dependencies not listed here, please edit this page or let