Opened 7 years ago

Closed 7 years ago

#971 closed defect (fixed)

Current trunk appears not to build on OSX 10.7

Reported by: tfb Owned by:
Priority: normal Milestone:
Component: other Version: trunk
Keywords: Cc:

Description

This may be idiocy on my part (more than likely). If more information is needed (or if I am indeed an idiot) let me know.

I'm running 10.7.4: uname -a says Darwin kingston.local 11.4.0 Darwin Kernel Version 11.4.0: Mon Apr 9 19:33:05 PDT 2012; root:xnu-1699.26.8~1/RELEASE_I386 i386. I think Xcode and so on is all up to date.

I'm at r15371, which I think should be the current trunk: I have updated after Gary's "trunk is OK now" message the other day and did not do a build during that window.

I have formerly been able to build on Lion (almost the only thing Apple did not manage to break).

I have deleted and let SVN put back the various image files.

I get this:

kingston$ ccl -n
Welcome to Clozure Common Lisp Version 1.7-dev-r14869  (DarwinX8664)!
? (ccl:rebuild-ccl :full t :allow-constant-redefinition t :allow-other-keys t)
Rebuilding Clozure Common Lisp using Version 1.7-dev-r14869  (DarwinX8664)
;Building lisp-kernel ...
> Error: Error(s) during kernel compilation.
>        gm4 -DDARWIN -DX86 -DX8664 -DTCR_IN_GPR -I../ ../x86-spjump64.s | as -arch x86_64 -g -o x86-spjump64.o
>        gm4 -DDARWIN -DX86 -DX8664 -DTCR_IN_GPR -I../ ../x86-spentry64.s | as -arch x86_64 -g -o x86-spentry64.o
>        gm4 -DDARWIN -DX86 -DX8664 -DTCR_IN_GPR -I../ ../x86-subprims64.s | as -arch x86_64 -g -o x86-subprims64.o
>        gm4 -DDARWIN -DX86 -DX8664 -DTCR_IN_GPR -I../ ../imports.s | as -arch x86_64 -g -o imports.o
>        cc -include ../platform-darwinx8664.h -c ../pmcl-kernel.c -arch x86_64 -DDARWIN -DX86 -DX8664 -DTCR_IN_GPR -DSVN_REVISION="15371" -D_DARWIN_NO_64_BIT_INODE -DUSE_DTRACE \
>        	-g -O2 -Wno-format  \
>        	 -I. -mmacosx-version-min=10.5 -isysroot / -o pmcl-kernel.o
>        cc -include ../platform-darwinx8664.h -c ../gc-common.c -arch x86_64 -DDARWIN -DX86 -DX8664 -DTCR_IN_GPR -DSVN_REVISION="15371" -D_DARWIN_NO_64_BIT_INODE -DUSE_DTRACE \
>        	-g -O2 -Wno-format  \
>        	 -I. -mmacosx-version-min=10.5 -isysroot / -o gc-common.o
>        ../x86-spentry64.s:4233:32-bit absolute addressing is not supported for x86-64
>        ../x86-spentry64.s:4233:cannot do signed 4 byte relocation
>        ../x86-spentry64.s:4237:32-bit absolute addressing is not supported for x86-64
>        ../x86-spentry64.s:4237:cannot do signed 4 byte relocation
>        ../x86-spentry64.s:4427:32-bit absolute addressing is not supported for x86-64
>        ../x86-spentry64.s:4427:cannot do signed 4 byte relocation
>        ../x86-spentry64.s:4431:32-bit absolute addressing is not supported for x86-64
>        ../x86-spentry64.s:4431:cannot do signed 4 byte relocation
>        make: *** [x86-spentry64.o] Error 1
>        cc -include ../platform-darwinx8664.h -c ../x86-gc.c -arch x86_64 -DDARWIN -DX86 -DX8664 -DTCR_IN_GPR -DSVN_REVISION="15371" -D_DARWIN_NO_64_BIT_INODE -DUSE_DTRACE \
>        	-g -O2 -Wno-format  \
>        	 -I. -mmacosx-version-min=10.5 -isysroot / -o x86-gc.o
>        cc -include ../platform-darwinx8664.h -c ../bits.c -arch x86_64 -DDARWIN -DX86 -DX8664 -DTCR_IN_GPR -DSVN_REVISION="15371" -D_DARWIN_NO_64_BIT_INODE -DUSE_DTRACE \
>        	-g -O2 -Wno-format  \
>        	 -I. -mmacosx-version-min=10.5 -isysroot / -o bits.o
>        cc -include ../platform-darwinx8664.h -c ../x86-exceptions.c -arch x86_64 -DDARWIN -DX86 -DX8664 -DTCR_IN_GPR -DSVN_REVISION="15371" -D_DARWIN_NO_64_BIT_INODE -DUSE_DTRACE \
>        	-g -O2 -Wno-format  \
>        	 -I. -mmacosx-version-min=10.5 -isysroot / -o x86-exceptions.o
>        cc -include ../platform-darwinx8664.h -c ../x86-utils.c -arch x86_64 -DDARWIN -DX86 -DX8664 -DTCR_IN_GPR -DSVN_REVISION="15371" -D_DARWIN_NO_64_BIT_INODE -DUSE_DTRACE \
>        	-g -O2 -Wno-format  \
>        	 -I. -mmacosx-version-min=10.5 -isysroot / -o x86-utils.o
>        cc -include ../platform-darwinx8664.h -c ../thread_manager.c -arch x86_64 -DDARWIN -DX86 -DX8664 -DTCR_IN_GPR -DSVN_REVISION="15371" -D_DARWIN_NO_64_BIT_INODE -DUSE_DTRACE \
>        	-g -O2 -Wno-format  \
>        	 -I. -mmacosx-version-min=10.5 -isysroot / -o thread_manager.o
>        cc -include ../platform-darwinx8664.h -c ../lisp-debug.c -arch x86_64 -DDARWIN -DX86 -DX8664 -DTCR_IN_GPR -DSVN_REVISION="15371" -D_DARWIN_NO_64_BIT_INODE -DUSE_DTRACE \
>        	-g -O2 -Wno-format  \
>        	 -I. -mmacosx-version-min=10.5 -isysroot / -o lisp-debug.o
>        ../thread_manager.c:1751:1: warning: control may reach end of non-void function [-Wreturn-type]
>        }
>        ^
>        cc -include ../platform-darwinx8664.h -c ../image.c -arch x86_64 -DDARWIN -DX86 -DX8664 -DTCR_IN_GPR -DSVN_REVISION="15371" -D_DARWIN_NO_64_BIT_INODE -DUSE_DTRACE \
>        	-g -O2 -Wno-format  \
>        	 -I. -mmacosx-version-min=10.5 -isysroot / -o image.o
>        ../image.c:376:2: warning: implicit declaration of function 'set_nil' is invalid in C99 [-Wimplicit-function-declaration]
>                set_nil(image_nil);
>                ^
>        ../image.c:386:2: warning: implicit declaration of function 'make_dynamic_heap_executable' is invalid in C99 [-Wimplicit-function-declaration]
>                make_dynamic_heap_executable(a->low, a->active);
>                ^
>        ../image.c:414:9: warning: implicit declaration of function 'lower_heap_start' is invalid in C99 [-Wimplicit-function-declaration]
>                lower_heap_start(static_cons_area->low,a);
>                ^
>        ../image.c:419:2: warning: implicit declaration of function 'xMakeDataExecutable' is invalid in C99 [-Wimplicit-function-declaration]
>                xMakeDataExecutable(a->low, a->active - a->low);
>                ^
>        1 warning generated.
>        cc -include ../platform-darwinx8664.h -c ../memory.c -arch x86_64 -DDARWIN -DX86 -DX8664 -DTCR_IN_GPR -DSVN_REVISION="15371" -D_DARWIN_NO_64_BIT_INODE -DUSE_DTRACE \
>        	-g -O2 -Wno-format  \
>        	 -I. -mmacosx-version-min=10.5 -isysroot / -o memory.o
>        ../memory.c:154:3: warning: implicit declaration of function 'raise_limit' is invalid in C99 [-Wimplicit-function-declaration]
>          raise_limit();
>          ^
>        4 warnings generated.
>        cc -include ../platform-darwinx8664.h -c ../unix-calls.c -arch x86_64 -DDARWIN -DX86 -DX8664 -DTCR_IN_GPR -DSVN_REVISION="15371" -D_DARWIN_NO_64_BIT_INODE -DUSE_DTRACE \
>        	-g -O2 -Wno-format  \
>        	 -I. -mmacosx-version-min=10.5 -isysroot / -o unix-calls.o
>        cc -include ../platform-darwinx8664.h -c ../mach-o-image.c -arch x86_64 -DDARWIN -DX86 -DX8664 -DTCR_IN_GPR -DSVN_REVISION="15371" -D_DARWIN_NO_64_BIT_INODE -DUSE_DTRACE \
>        	-g -O2 -Wno-format  \
>        	 -I. -mmacosx-version-min=10.5 -isysroot / -o mach-o-image.o
>        gm4 -DDARWIN -DX86 -DX8664 -DTCR_IN_GPR -I../ ../x86-asmutils64.s | as -arch x86_64 -g -o x86-asmutils64.o
>        cc -include ../platform-darwinx8664.h -c ../lispdcmd.c -arch x86_64 -DDARWIN -DX86 -DX8664 -DTCR_IN_GPR -DSVN_REVISION="15371" -D_DARWIN_NO_64_BIT_INODE -DUSE_DTRACE \
>        	-g -O2 -Wno-format  \
>        	 -I. -mmacosx-version-min=10.5 -isysroot / -o lispdcmd.o
>        1 warning generated.
>        cc -include ../platform-darwinx8664.h -c ../plprint.c -arch x86_64 -DDARWIN -DX86 -DX8664 -DTCR_IN_GPR -DSVN_REVISION="15371" -D_DARWIN_NO_64_BIT_INODE -DUSE_DTRACE \
>        	-g -O2 -Wno-format  \
>        	 -I. -mmacosx-version-min=10.5 -isysroot / -o plprint.o
>        ../mach-o-image.c:515:5: warning: implicit declaration of function 'prepare_to_write_dynamic_space' is invalid in C99 [-Wimplicit-function-declaration]
>            prepare_to_write_dynamic_space(managed_static_area);
>            ^
>        ../mach-o-image.c:570:3: warning: implicit declaration of function 'prepare_to_write_static_space' is invalid in C99 [-Wimplicit-function-declaration]
>          prepare_to_write_static_space(egc_was_enabled);
>          ^
>        ../mach-o-image.c:801:5: warning: implicit declaration of function 'set_nil' is invalid in C99 [-Wimplicit-function-declaration]
>            set_nil(image_nil);
>            ^
>        ../mach-o-image.c:819:5: warning: implicit declaration of function 'map_initial_reloctab' is invalid in C99 [-Wimplicit-function-declaration]
>            map_initial_reloctab(p, q);
>            ^
>        ../mach-o-image.c:820:5: warning: implicit declaration of function 'map_initial_markbits' is invalid in C99 [-Wimplicit-function-declaration]
>            map_initial_markbits(p, q);
>            ^
>        ../mach-o-image.c:825:5: warning: implicit declaration of function 'xMakeDataExecutable' is invalid in C99 [-Wimplicit-function-declaration]
>            xMakeDataExecutable(a->low, a->active - a->low);
>            ^
>        ../mach-o-image.c:829:5: warning: implicit declaration of function 'lower_heap_start' is invalid in C99 [-Wimplicit-function-declaration]
>            lower_heap_start(sc_start,a);
>            ^
>        cc -include ../platform-darwinx8664.h -c ../plsym.c -arch x86_64 -DDARWIN -DX86 -DX8664 -DTCR_IN_GPR -DSVN_REVISION="15371" -D_DARWIN_NO_64_BIT_INODE -DUSE_DTRACE \
>        	-g -O2 -Wno-format  \
>        	 -I. -mmacosx-version-min=10.5 -isysroot / -o plsym.o
>        cc -include ../platform-darwinx8664.h -c ../xlbt.c -arch x86_64 -DDARWIN -DX86 -DX8664 -DTCR_IN_GPR -DSVN_REVISION="15371" -D_DARWIN_NO_64_BIT_INODE -DUSE_DTRACE \
>        	-g -O2 -Wno-format  \
>        	 -I. -mmacosx-version-min=10.5 -isysroot / -o xlbt.o
>        cc -include ../platform-darwinx8664.h -c ../x86_print.c -arch x86_64 -DDARWIN -DX86 -DX8664 -DTCR_IN_GPR -DSVN_REVISION="15371" -D_DARWIN_NO_64_BIT_INODE -DUSE_DTRACE \
>        	-g -O2 -Wno-format  \
>        	 -I. -mmacosx-version-min=10.5 -isysroot / -o x86_print.o
>        ../x86_print.c:161:10: warning: type specifier missing, defaults to 'int' [-Wimplicit-int]
>          static tried_to_resolve_hook = false;
>          ~~~~~~ ^
>        7 warnings generated.
>        1 warning generated.
>        make: Target `all' not remade because of errors.
>        
> While executing: REBUILD-CCL, in process listener(1).
> Type :POP to abort, :R for a list of available restarts.
> Type :? for other options.
1 > 

Change History (1)

comment:1 Changed 7 years ago by gb

  • Resolution set to fixed
  • Status changed from new to closed

The errors from the assembler - complaints about 32-bit relocation and absolute addressing - are Apple's way of telling the rest of us that recent changes which attempted to use the same names for global variable references from assembly-language and C missed a few cases; mea culpa. That should be fixed in r15372.

The compiler warnings are coming from llvm; Apple's been moving away from gcc and towards llvm over the last few years, and XCode releases often ship with a few different C compilers (some of which try to provide compatibility with GCC frontends and some of which don't.) I have no idea what they're called or which is which or whether different XCode releases offer different defaults (though I suppose that this information is written down somewhere.) The warnings look legitimate (if sometimes of limited value) and I tried to suppress them in r15373, but I didn't bother to try to configure the default C compiler to reproduce these warnings.

If warnings are still present when rebuilding the kernel after updating to r15373, please re-open this and paste those warnings into a response.

Note: See TracTickets for help on using tickets.