Opened 12 years ago

Closed 10 years ago

#83 closed defect (worksforme)

Listener stops showing output

Reported by: gz Owned by: gb
Priority: minor Milestone:
Component: IDE Version:
Keywords: Cc:

Description

I've managed to load up most of anvita overnight, which generates a lot of listener output -- around 700K. Somewhere along the way, the listener has become very reluctant to scroll to the end of the buffer. M-> doesn't work, going to last shown line and doing ctl-f or ctl-n doesn't work, moving the scroll bar doesn't work (i.e. it scrolls, but never to the end of the buffer). At first I thought the lisp froze up, so I did cmd-A cmd-C to copy the listener output to emacs, and found there was more stuff at the bottom that wasn't showing in the IDE. The only thing I found that works is sometimes resizing the window will show you more. It doesn't unwedge it, it just shows more of whatever is available at the time, but any output after that still can't be scrolled into view.

Change History (4)

comment:1 Changed 12 years ago by gz

I have been unable to reproduce this (in a new lisp). I have reloaded all of anvita, and the listener is behaving fine. The contents of the listener is about 700K again, which is when this first started happening last time, so it's not strictly size related. Last time, I was still working on getting anvita to load, so there would be errors, I'd fix them and continue (and would get occasional IDE bugs that I'd also continue from), so maybe that had something to do with it.

comment:2 Changed 12 years ago by gz

Ok, I hit this bug again last night, but this time with only a few pages of output in the listener. So it isn't related to listener buffer size at all. New hypothesis: I did have a bunch of windows open, like a dozen or so, and probably had opened and closed a bunch more as I was working, and did a fair amount of copying and pasting and evaluation from buffers. All of that was also the case the first time it happened (when I was working on getting anvita loaded, and was hitting and fixing loading problems in various source files) and it was NOT the case the second time (when I just uneventfully reloaded anvita and the bug didn't come up). So it might be related to (some aspect of) working with multiple windows.

comment:3 Changed 11 years ago by jaj

  • Priority changed from major to minor

Since this is hard to reproduce, change priority to minor, and don't add to Cocoa IDE v1

comment:4 Changed 10 years ago by gb

  • Resolution set to worksforme
  • Status changed from new to closed

Whatever caused this likely changed a long time ago.

Note: See TracTickets for help on using tickets.