Opened 9 years ago

Closed 8 years ago

Last modified 8 years ago

#818 closed defect (fixed)

NSRunAlertPanel() hangs on Cocotron

Reported by: gb Owned by:
Priority: normal Milestone:
Component: Cocotron Version: trunk
Keywords: Cc:

Description

as of Cocotron 2845a0e2fa, doing:

(#_NSRunAlertPanel #@"title" #@"message" #@"Yes" #@"No" #@"Maybe")

from the main thread hangs, burning 100% CPU and (apparently) slowly leaking memory.

I haven't yet tried to create an ObjC example that demonstrates this, though it doesn't seem likely that it's CCL-specific.

Change History (3)

comment:2 Changed 8 years ago by gb

  • Resolution set to fixed
  • Status changed from new to closed

r14659 tries to workaround this, assuming that my understanding of the problem is correct.

comment:3 Changed 8 years ago by gb

(In [14660]) When modifying a document's textstorage on Cocotron, explicitly call the document's #/updateChangeCount: method. (This ordinarily is the responsibility of the document's NSUndoManager, but Cocotron's NSUndoManager support is broken.) This gives visual indication of the document's modified state in the containing window's titlebar and modeline and notifies the document controller that it should prompt to save modified documents. Since NSRunAlertPanel() seems to now be usable on Cocotron (see ticket:818), this fixes ticket:813.

Note: See TracTickets for help on using tickets.