Opened 9 years ago

Closed 9 years ago

#810 closed defect (worksforme)

(directoryp (get-ide-bundle-path)) returns nil on the Windows IDE

Reported by: ender2012 Owned by:
Priority: normal Milestone:
Component: Cocotron Version: trunk
Keywords: Cc:

Description

This is especially annoying when build an application, because the build-application method uses (directoryp (get-ide-bundle-path)) as error checking and this always returns false on Windows so the build-application fails here.

To reproduce: In the listener simply type (ccl::directoryp (ccl::get-ide-bundle-path)) on the mac this will return t and on the pc it will return false (even though the return from get-ide-bundle-path is clearly a directory). Part of the problem may have to do with (get-ide-bundle-path) returning in a mac oriented format on the PC (it returns something like /Users/Mike?... instead c:\users\mike...)

Change History (1)

comment:1 Changed 9 years ago by rme

  • Resolution set to worksforme
  • Status changed from new to closed

This works for me with current trunk sources. Please re-open the ticket if I'm missing the point entirely.

? (lisp-implementation-version)
"Version 1.7-dev-r14647M-trunk  (WindowsX8632)"
? (ccl::get-ide-bundle-path)
#P"C:/cygwin/home/rme/ccl-trunk/temp bundle32.app/"
? (directoryp *)
T
? 
Note: See TracTickets for help on using tickets.