Opened 9 years ago

Closed 9 years ago

#775 closed defect (fixed)

freebsd test suite failures

Reported by: rme Owned by:
Priority: normal Milestone: Clozure CL 1.6
Component: ANSI CL Compliance Version: trunk
Keywords: Cc:

Description

The freebsd ports have a few test failures:

32 bit:

6 out of 21863 total tests failed: 
   CL-TEST::FUNCALL.ERROR.1, CL-TEST::FUNCALL.ERROR.2, CL-TEST::FUNCALL.ERROR.3, 
   CL-TEST::EXP.ERROR.6, CL-TEST::EXP.ERROR.7, CL-TEST::LISTEN.7.

see: http://setf.clozure.com:8010/builders/freebsdx8632/builds/1/steps/shell_3/logs/stdio

64-bit:

1 out of 21869 total tests failed: 
   CL-TEST::LISTEN.7.

see: http://setf.clozure.com:8010/builders/freebsdx8664/builds/1/steps/shell_3/logs/stdio

Change History (4)

comment:1 Changed 9 years ago by gb

I've seen the EXP and LISTEN failures, but haven't seen and can't reproduce the first two.

I wonder if this is some low-level exception handling difference between different FreeBSD versions, or whether a VM behaves differently than real hardware does.

comment:2 Changed 9 years ago by rme

Test case so I don't forget:

(defun foo () (funcall 'progn 12))

comment:3 Changed 9 years ago by rme

(In [14428]) In %get-xcf-byte, xcf.relative-pc (which is a fixnum) can be negative, and %int-to-ptr doesn't like that. Go through some gyrations to account for that. See ticket:775.

comment:4 Changed 9 years ago by rme

  • Resolution set to fixed
  • Status changed from new to closed

r14437 fixes the cl:listen failure.

r14444 and r14445 fix the cl:exp errors.

Note: See TracTickets for help on using tickets.