Opened 9 years ago

Closed 9 years ago

#774 closed defect (duplicate)

ccl 1.5 sigseg when launched via make on x86_64

Reported by: informatimago Owned by:
Priority: normal Milestone:
Component: Runtime (threads, GC) Version: trunk
Keywords: sigseg Cc:

Description (last modified by gb)

On gentoo, with ccl from dev-lisp/clozurecl-1.5, when running ccl from make, it cores dump on sigseg immediately, but when I run the same command in the shell, it succeeds. The difference in env output doesn't seem significative.

I join a tarball with the executable and the core dump.

[pjb@kuiper :0.0 lisp]$ uname -a
Linux kuiper 2.6.34-xen-r3-kvm-nvidia-joy-c7 #3 SMP Fri Oct 8 12:01:59 CEST 2010 x86_64 Intel(R) Core(TM) i7 CPU 950 @ 3.07GHz GenuineIntel GNU/Linux
[pjb@kuiper :0.0 lisp]$ make ccl




;;;;;;======================================================================
;;;; Compiling with Clozure Common Lisp
/bin/sh: line 4: 11107 Segmentation fault      (core dumped) LC_CTYPE=en_US.UTF-8 ccl --quiet --no-init --eval '(DECLAIM (OPTIMIZE (SAFETY 3) (DEBUG 3) (SPEED 0) (SPACE 0)))' --eval '(load "compile.lisp")' --eval '(ccl:quit)'
make: *** [ccl] Error 139
[pjb@kuiper :0.0 lisp]$ env > ccl-environment-in-emacs-shell
[pjb@kuiper :0.0 lisp]$ LC_CTYPE=en_US.UTF-8 ccl --quiet --no-init --eval '(DECLAIM (OPTIMIZE (SAFETY 3) (DEBUG 3) (SPEED 0) (SPACE 0)))' --eval '(load "compile.lisp")' --eval '(ccl:quit)' > success
(ccl:quit)
[pjb@kuiper :0.0 lisp]$ echo $?
0
[pjb@kuiper :0.0 lisp]$ for f in  ccl-environment-in-* ; do sort -o ${f}.sorted $f ; done
[pjb@kuiper :0.0 lisp]$ diff *.sorted
66a67,68
> MAKEFLAGS=
> MAKELEVEL=1
67a70
> MFLAGS=
77d79
< OLDPWD=/home/pjb
82d83
< PS1=`period-cookie`[\u@\h $DISPLAY \W]\$ 
93c94
< SHLVL=6
---
> SHLVL=7

Attachments (1)

ccl-sigseg.tar.bz2 (106.5 KB) - added by informatimago 9 years ago.
tarball with core and executable.

Download all attachments as: .zip

Change History (3)

Changed 9 years ago by informatimago

tarball with core and executable.

comment:1 Changed 9 years ago by gb

  • Description modified (diff)

comment:2 Changed 9 years ago by gb

  • Component changed from other to Runtime (threads, GC)
  • Resolution set to duplicate
  • Status changed from new to closed

I don't know whether Gentoo's Makefile has anything to do with this, but that isn't something that we distribute or have any control over. (If "compile.lisp" is intended to rebuild the lisp image with those optimization settings, that almost certainly won't work, but you're apparently crashing with a SIGSEGV way before that would start to misbehave.)

The SIGSEGV is almost certainly caused by the (apparent) Linux kernel bug described in ticket:731. The workaround involves

I have no idea how to do the second step as things are packaged for Gentoo.

Note: See TracTickets for help on using tickets.