Opened 12 years ago

Closed 10 years ago

#68 closed defect (worksforme)

NS out of bounds errors while in the editor

Reported by: gz Owned by: gb
Priority: minor Milestone: Cocoa IDE v1
Component: IDE Version:
Keywords: Cc:

Description

The first time I ran the IDE, I did (apropos "INIT") and then was mousing around in the listener trying to figure out why the display was so weird (which I eventually narrowed down to issues reported in tickets #66 and #67). I clicked around, did incremental searches, and resized the window - I don't think I did anything else. Anyway, I noticed a bunch of "index beyond array bounds" messages in the terminal window. I saved the terminal output and have attached it here. At the time I thought my lisp was fried so I quit and restarted, and have been unable to duplicate this since then, but am reporting it for the record, in case the backtraces contain enough information to figure out what was going on...

Attachments (2)

backtraces-1.txt (250.1 KB) - added by gz 12 years ago.
Terminal output, part 1
backtraces-2.txt (201.0 KB) - added by gz 12 years ago.
Terminal output, part 2

Download all attachments as: .zip

Change History (5)

Changed 12 years ago by gz

Terminal output, part 1

Changed 12 years ago by gz

Terminal output, part 2

comment:1 Changed 12 years ago by gz

I had to split the attachment into two files due to trac attachment size limitations.

comment:2 Changed 11 years ago by jaj

  • Milestone set to Cocoa IDE v1
  • Priority changed from major to minor

Since I can't reproduce this, I'm changing the priority to minor.

comment:3 Changed 10 years ago by gz

  • Resolution set to worksforme
  • Status changed from new to closed

This was reported two years ago and much of this code has been rewritten and/or reorganized. There is nothing to be done here.

Note: See TracTickets for help on using tickets.