Opened 10 years ago

Closed 10 years ago

#627 closed enhancement (fixed)

Windows 1.4 map-file-to-octet-vector

Reported by: wvanflee Owned by: gb
Priority: major Milestone: Clozure CL 1.5
Component: Foreign Function Interface Version: trunk
Keywords: Cc:

Description

The function "map-file-to-octet-vector" is defined in the Linux version of CCL 1.3 but not the Windows version of CCL 1.3. This is causing ACL2 to not be abel to certify the book "serialize". Being able to run regression books in ACL2 on Windows will verify the fix.

Change History (3)

comment:1 Changed 10 years ago by gb

  • Owner set to gb
  • Status changed from new to assigned
  • Type changed from defect to enhancement

MAP-FILE-TO-OCTET-VECTOR doesn't exist on Windows versions of CCL because the underlying OS functionality that's used to support memory-mapped files is significantly different from that provided by Unix-based OSes and it's not entirely clear that the Windows functionality is adequate.

I'll look at it and either implement what's missing or be better able to conclude that it's not implementable.

comment:2 Changed 10 years ago by gb

  • Component changed from IDE to Foreign Function Interface

comment:3 Changed 10 years ago by rme

  • Resolution set to fixed
  • Status changed from assigned to closed

Fixed in r13209: Separate OS-level file-mapping stuff from other file-mapping stuff, provide implementations of MAP-FILE-TO-IVECTOR, UNMAP-IVECTOR, etc. for Windows.

Note: See TracTickets for help on using tickets.