Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#619 closed defect (invalid)

Image build with save-application() hangs on gc

Reported by: rigus Owned by: gb
Priority: critical Milestone:
Component: Runtime (threads, GC) Version: trunk
Keywords: save-application, gc, hangs Cc:

Description

An image build with

(ccl::save-application "~/lisp/projects/gc-bug"

:toplevel-function (lambda () (ccl::gc) (#exit 0)) :prepend-kernel "~/lisp/ccl/lx86cl64" :mode #o755)

hangs on (gc). I have tested this with the newest (as of 2009-10-30) code from svn, both in 32 and 64 bit mode, on Linux. -- Paul

Change History (4)

comment:1 Changed 10 years ago by gb

  • Status changed from new to assigned

I can't reproduce this, though I remember that there was a bug (ticket:464) several months ago that had similar symptoms.

What exactly does (LISP-IMPLEMENTATION-VERSION) return ?

comment:2 Changed 10 years ago by rigus

It returns "Version 1.3-r11936 (LinuxX8664)". The same happens for me on Darwin (same version, DarwinX8664, MacOS 10.6.1). I do run the save-appliation code in an Emacs/Slime? environment, in a freshly started Lisp without init file. (I just tested it on the command line, with same result.)

comment:3 Changed 10 years ago by gb

  • Resolution set to invalid
  • Status changed from assigned to closed

The bug that I was thinking about was fixed in r11984. Please rebuild your lisp or otherwise use a newer image. See http://trac.clozure.com/openmcl/wiki/UpdatingFromSource

comment:4 Changed 10 years ago by rigus

Thanks for pointing this out. I should have guessed that the newest SVN source doesn't contain the newest image (or at least read the documentation). -- Paul

Note: See TracTickets for help on using tickets.