Opened 10 years ago

Closed 10 years ago

#589 closed defect (fixed)

Multiple forms pasted into the listener causes Hemlock to barf

Reported by: rongarret Owned by: rme
Priority: normal Milestone:
Component: IDE Version: trunk
Keywords: Cc:

Description

Cut and past any two forms separated by a line break into the listener and hit return. The result is the following:

Lisp error: "value NIL is not of the expected type REAL."
 (442390) : 0 (PRINT-CALL-HISTORY :CONTEXT NIL :PROCESS NIL :ORIGIN NIL :DETAILED-P T :COUNT 1152921504606846975 :START-FRAME-NUMBER 0 :STREAM #<SYNONYM-STREAM to *TERMINAL-IO* #x300041BC2C4D> :PRINT-LEVEL 2 :PRINT-LENGTH 5 :SHOW-INTERNAL-FRAMES NIL :FORMAT :TRADITIONAL) 845
  (&KEY :CONTEXT :PROCESS :ORIGIN :DETAILED-P :COUNT :START-FRAME-NUMBER :STREAM :PRINT-LEVEL :PRINT-LENGTH :SHOW-INTERNAL-FRAMES :FORMAT)
   CCL::CONTEXT: NIL
   PROCESS: NIL
   CCL::ORIGIN: NIL
   CCL::DETAILED-P: T
   COUNT: 1152921504606846975
   CCL::START-FRAME-NUMBER: 0
   STREAM: #<SYNONYM-STREAM to *TERMINAL-IO* #x300041BC2C4D>
   CCL::PRINT-LEVEL: 2
   CCL::PRINT-LENGTH: 5
   CCL::SHOW-INTERNAL-FRAMES: NIL
   FORMAT: :TRADITIONAL

  CCL::FRAME-NUMBER: 0
  *BACKTRACE-PRINT-LEVEL*: 2
  *BACKTRACE-PRINT-LENGTH*: 5
  *BACKTRACE-FORMAT*: :TRADITIONAL
  *STANDARD-OUTPUT*: #<SYNONYM-STREAM to *TERMINAL-IO* #x300041BC2C4D>
  *PRINT-CIRCLE*: NIL

 (4424F8) : 1 (MAYBE-LOG-CALLBACK-ERROR #<TYPE-ERROR #x300041F3F5BD>) 1605
  (CONDITION)
   CONDITION: #<TYPE-ERROR #x300041F3F5BD>

  GUI::EMSG: "value NIL is not of the expected type REAL."
  #:G5569: (ERROR)
  CCL::%HANDLERS%: ((ERROR) (ERROR) (CONDITION #) (CONDITION #))

 (442550) : 2 (FUNCALL #'#<#<STANDARD-METHOD HEMLOCK-EXT:REPORT-HEMLOCK-ERROR (HI:HEMLOCK-VIEW T T)>> #<HI:HEMLOCK-VIEW #x300041D5634D> #<TYPE-ERROR #x300041F3F5BD> T) 53
  (GUI::VIEW CONDITION GUI::DEBUG-P)
   GUI::VIEW: #<HI:HEMLOCK-VIEW #x300041D5634D>
   CONDITION: #<TYPE-ERROR #x300041F3F5BD>
   GUI::DEBUG-P: T



 (442580) : 3 (LISP-ERROR-ERROR-HANDLER #<TYPE-ERROR #x300041F3F5BD> :DEBUG-P T) 445
  (CONDITION &KEY :DEBUG-P)
   CONDITION: #<TYPE-ERROR #x300041F3F5BD>
   HI::DEBUG-P: T

  *STANDARD-OUTPUT*: #<SYNONYM-STREAM to *TERMINAL-IO* #x300041BC2CCD>
  #:G12025: (ERROR)
  CCL::%HANDLERS%: ((ERROR) (CONDITION #) (CONDITION #))

 (4425F0) : 4 (SIGNAL #<TYPE-ERROR #x300041F3F5BD>) 973
  (CONDITION &REST CCL::ARGS)
   CONDITION: #<TYPE-ERROR #x300041F3F5BD>
   CCL::ARGS: NIL

  CCL::%HANDLERS%: ((CONDITION #) (CONDITION #))
  CCL::TAG: (ERROR #<Compiled-function # (Non-Global)  #x30004156751F>)
  CCL::HANDLERS: (ERROR #<Compiled-function # (Non-Global)  #x30004156751F>)
  CCL::FN: #<Compiled-function (:INTERNAL #) (Non-Global)  #x30004156751F>

 (442648) : 5 (%ERROR #<TYPE-ERROR #x300041F3F5BD> NIL 558305) 117
  (CONDITION CCL::ARGS CCL::ERROR-POINTER)
   CONDITION: #<TYPE-ERROR #x300041F3F5BD>
   CCL::ARGS: NIL
   CCL::ERROR-POINTER: 558305



 (442670) : 6 (FUNCALL #'#<CCL::DEFAULT-REQUIRE-TYPE-RESTARTS> 558305 NIL REAL) 1045
  (CCL::FRAME-PTR CCL::VALUE CCL::TYPESPEC)
   CCL::FRAME-PTR: 558305
   CCL::VALUE: NIL
   CCL::TYPESPEC: REAL

  CONDITION: #<TYPE-ERROR #x300041F3F5BD>
  #:USE-VALUE: #<RESTART USE-VALUE #x49359D>
  #:G135060: (#<RESTART USE-VALUE #x49359D>)
  CCL::%RESTARTS%: ((#<# # #x49359D>) (#<# # #x4936FD>) (#<# # #x49399D> #<# # #x4939ED>) (#<# # #x493F3D>))
  #:G135061: #<TYPE-ERROR #x300041F3F5BD>
  CCL::*CONDITION-RESTARTS*: ((#<# # #x49359D> . #))

 (442708) : 7 (>-2 0 NIL) 413
  (CCL::X CCL::Y)
   CCL::X: 0
   CCL::Y: NIL

  #:G164212: 0
  #:G164215: 3

 (442738) : 8 (<=-2 0 NIL) 37
  (CCL::X CCL::Y)
   CCL::X: 0
   CCL::Y: NIL



 (442758) : 9 (COPY-LINE-CHARPROPS #<Hemlock Line "? (list 1 2 3)"> :START 2 :END 0) 1149
  (HI:LINE &KEY :START :END)
   HI:LINE: #<Hemlock Line "? (list 1 2 3)">
   HI::START: 2
   HI::END: 0

  HI::CHANGES: #(#S(HI::CHARPROPS-CHANGE :INDEX 2 :PLIST NIL))
  HI::NEW-CHANGES: #()
  HI::START-IDX: 0
  HI::END-IDX: NIL
  HI::I: 0

 (4427C8) : 10 (COPY-REGION #<Hemlock Region "(list 1 2 3)/(list 1 2 3)/">) 1549
  (HEMLOCK-INTERFACE:REGION)
   HEMLOCK-INTERFACE:REGION: #<Hemlock Region "(list 1 2 3)/(list 1 2 3)/">

  HI::START: #<Hemlock Mark "? ^(list 1 2 3)">
  HI::END: #<Hemlock Mark "^">
  HI::FIRST-LINE: #<Hemlock Line "? (list 1 2 3)">
  HI::LAST-LINE: #<Hemlock Line "">
  HI::FIRST-CHARPOS: 2
  HI::LAST-CHARPOS: 0
  COUNT: 19
  HI::FIRST-CHARS: "? (list 1 2 3)"
  LENGTH: 12
  HI::CHARS: "(list 1 2 3)"
  HI::FIRST-COPIED-LINE: #<Hemlock Line "(list 1 2 3)">

 (442850) : 11 (SEND-INPUT-REGION-TO-LISP) 909
  NIL

  HEMLOCK::INPUT-MARK: #<Hemlock Mark "? ^(list 1 2 3)">
  HEMLOCK::END-MARK: #<Hemlock Mark "^">
  HEMLOCK::INPUT-REGION: #<Hemlock Region "(list 1 2 3)/(list 1 2 3)/">
  HEMLOCK::R: #<Hemlock Region "(list 1 2 3)/(list 1 2 3)/">
  STRING: "(list 1 2 3)
(list 1 2 3)
"
  HI:RING: #<Hemlock Ring>

 (4428A0) : 12 (FUNCALL #'#<#<STANDARD-METHOD HI::EXECUTE-HEMLOCK-KEY (HI:HEMLOCK-VIEW T)>> #<HI:HEMLOCK-VIEW #x300041D5634D> #<Key-Event Return>) 1061
  (HI::VIEW HI::KEY)
   HI::VIEW: #<HI:HEMLOCK-VIEW #x300041D5634D>
   HI::KEY: #<Key-Event Return>

  HI::*SAVED-STANDARD-OUTPUT*: #<SYNONYM-STREAM to *TERMINAL-IO* #x300041BC2CCD>
  *STANDARD-OUTPUT*: #<GUI::COCOA-LISTENER-OUTPUT-STREAM #x300041D55A0D>
  HI::MAIN-BINDING: #<Hemlock Command "Confirm Listener Input">
  HI::TRANSPARENT-BINDINGS: NIL
  HI::*LAST-LAST-COMMAND-TYPE*: NIL
  HI::*LAST-PREFIX-ARGUMENT*: NIL

 (442948) : 13 (FUNCALL #'#<(:INTERNAL (HI::HANDLE-HEMLOCK-EVENT (HI:HEMLOCK-VIEW T)))>) 517
  NIL

  #:G12196: #<RESTART HI::EXIT-EVENT-HANDLER #x4936FD>
  #:G12192: (#<RESTART HI::EXIT-EVENT-HANDLER #x4936FD>)
  CCL::%RESTARTS%: ((#<# # #x4936FD>) (#<# # #x49399D> #<# # #x4939ED>) (#<# # #x493F3D>))
  #:G12197: #<Compiled-function (:INTERNAL #) (Non-Global)  #x30004156751F>
  #:G12198: (ERROR #<Compiled-function # (Non-Global)  #x30004156751F>)
  CCL::%HANDLERS%: ((ERROR #) (CONDITION #) (CONDITION #))
  HI::KEY: #<Key-Event Return>
  HI::VIEW: #<HI:HEMLOCK-VIEW #x300041D5634D>

 (4429C0) : 14 (INVOKE-MODIFYING-BUFFER-STORAGE #<Hemlock Buffer "Listener"> #<COMPILED-LEXICAL-CLOSURE (:INTERNAL #) #x300041F3FDCF>) 445
  (GUI::BUFFER GUI::THUNK)
   GUI::BUFFER: #<Hemlock Buffer "Listener">
   GUI::THUNK: #<COMPILED-LEXICAL-CLOSURE (:INTERNAL #) #x300041F3FDCF>

  GUI::OLD: NIL

 (442A20) : 15 (FUNCALL #'#<#<STANDARD-METHOD HI::HANDLE-HEMLOCK-EVENT (HI:HEMLOCK-VIEW T)>> #<HI:HEMLOCK-VIEW #x300041D5634D> #<Key-Event Return>) 893
  (HI::VIEW HI::KEY)
   HI::VIEW: #<HI:HEMLOCK-VIEW #x300041D5634D>
   HI::KEY: #<Key-Event Return>

  #:ABORT-BREAK: #<RESTART ABORT-BREAK #x4939ED>
  #:ABORT: #<RESTART ABORT #x49399D>
  #:G12189: (#<RESTART ABORT #x49399D> #<RESTART ABORT-BREAK #x4939ED>)
  CCL::%RESTARTS%: ((#<# # #x49399D> #<# # #x4939ED>) (#<# # #x493F3D>))
  HI::*CURRENT-VIEW*: #<HI:HEMLOCK-VIEW #x300041D5634D>
  HI::*CURRENT-BUFFER*: #<Hemlock Buffer "Listener">
  HI::*NEXT-VIEW-START*: NIL
  HI::TEXT-BUFFER: #<Hemlock Buffer "Listener">
  MOD: (43 105 . 105)

 (442AD8) : 16 (%CALL-NEXT-METHOD (NIL #<STANDARD-METHOD HI::HANDLE-HEMLOCK-EVENT #> . 558467)) 1005
  (CCL::MAGIC &REST CCL::ARGS)
   CCL::MAGIC: (NIL #<STANDARD-METHOD HI::HANDLE-HEMLOCK-EVENT #> . 558467)
   CCL::ARGS: NIL

  CCL::NEXT-METHODS: (#<STANDARD-METHOD HI::HANDLE-HEMLOCK-EVENT #>)
  CCL::ARGS: 558467
  CDR: NIL
  METHOD-FUNCTION: #<METHOD-FUNCTION HI::HANDLE-HEMLOCK-EVENT (HI:HEMLOCK-VIEW T)>

 (442B58) : 17 (FUNCALL #'#<#<STANDARD-METHOD HI::HANDLE-HEMLOCK-EVENT :AROUND (HI:HEMLOCK-VIEW T)>> #<HI:HEMLOCK-VIEW #x300041D5634D> #<Key-Event Return>) 173
  (GUI::VIEW GUI::EVENT)
   GUI::VIEW: #<HI:HEMLOCK-VIEW #x300041D5634D>
   GUI::EVENT: #<Key-Event Return>

  #:NEXT-METHOD-CONTEXT: (NIL #<STANDARD-METHOD HI::HANDLE-HEMLOCK-EVENT #> . 558467)
  #:G26686: #<NS-AUTORELEASE-POOL <NSAutoreleasePool: 0x1c85e0> (#x1C85E0)>

 (442BC0) : 18 (%%STANDARD-COMBINED-METHOD-DCODE (#<STANDARD-METHOD HI::HANDLE-HEMLOCK-EVENT :AROUND #> #<STANDARD-METHOD HI::HANDLE-HEMLOCK-EVENT #>) 558467) 693
  (CCL::METHODS CCL::ARGS)
   CCL::METHODS: (#<STANDARD-METHOD HI::HANDLE-HEMLOCK-EVENT :AROUND #> #<STANDARD-METHOD HI::HANDLE-HEMLOCK-EVENT #>)
   CCL::ARGS: 558467

  CCL::CAR-METHS: #<STANDARD-METHOD HI::HANDLE-HEMLOCK-EVENT :AROUND (HI:HEMLOCK-VIEW T)>
  CCL::CELL-2: (#<STANDARD-METHOD HI::HANDLE-HEMLOCK-EVENT #> . 558467)
  CCL::MAGIC: (NIL #<STANDARD-METHOD HI::HANDLE-HEMLOCK-EVENT #> . 558467)
  #:G103037: #<METHOD-FUNCTION HI::HANDLE-HEMLOCK-EVENT :AROUND (HI:HEMLOCK-VIEW T)>

 (442C30) : 19 (FUNCALL #'#<GUI::|-[HemlockTextstorageTextView keyDown:]|> 17591849975328) 1253
  (#:G26652)
   #:G26652: 17591849975328

  #:G26667: #<A Foreign Pointer [stack-allocated] #x7FFF5FBFF100>
  #:G26653: #<A Foreign Pointer [stack-allocated] #x7FFF5FBFF100>
  #:COMPILER-VAR: (NIL)
  #:G26657: #<COMPILED-LEXICAL-CLOSURE (:INTERNAL GUI::|-[HemlockTextstorageTextView keyDown:]|) #x493BDF>
  #:G26668: (CONDITION #<COMPILED-LEXICAL-CLOSURE # #x493BDF>)
  CCL::%HANDLERS%: ((CONDITION #) (CONDITION #))
  GUI::SELF: #<HEMLOCK-TEXT-VIEW <HemlockTextView: 0xb405f00>
    Frame = {{0.00, 0.00}, {592.00, 910.00}}, Bounds = {{0.00, 0.00}, {592.00, 910.00}}
    Horizontally resizable: NO, Vertically resizable: YES
    MinSize = {592.00, 910.00}, MaxSize = {10000000.00, 10000000.00}
 (#xB405F00)>
  GUI::EVENT: #<NS-EVENT NSEvent: type=KeyDown loc=(0,962) time=600541.2 flags=0x100 win=0x0 winNum=9780 ctxt=0x0 chars="
" unmodchars="
" repeat=0 keyCode=36 (#xB41D6E0)>
  GUI::VIEW: #<HI:HEMLOCK-VIEW #x300041D5634D>
  GUI::QUOTE-P: NIL
  GUI::HEMLOCK-KEY: #<Key-Event Return>

 (442CB0) : 20 (%PASCAL-FUNCTIONS% 73 17591849975328) 365
  (CCL::INDEX CCL::ARGS-PTR-FIXNUM)
   CCL::INDEX: 73
   CCL::ARGS-PTR-FIXNUM: 17591849975328

  CCL::LISP-FUNCTION: #<Compiled-function GUI::|-[HemlockTextstorageTextView keyDown:]| (Non-Global)  #x3000417F58CF>
  WITHOUT-INTERRUPTS: NIL
  CCL::*CALLBACK-TRACE-P*: NIL

 (442D70) : 21 (FUNCALL #'#<Anonymous Function #x30004142838F> #<A Foreign Pointer [stack-allocated] (:* #) #x7FFF5FBFF5B0> #<A Foreign Pointer #x7FFF830E7D48> #<NS-EVENT NSEvent: type=KeyDown loc=(0,962) time=600541.2 flags=0x100 win=0x0 winNum=9780 ctxt=0x0 chars="
" unmodchars="
" repeat=0 keyCode=36 (#xB41D6E0)>) 365
  (#:G4925 #:G4926 CCL::ARG0)
   #:G4925: #<A Foreign Pointer [stack-allocated] (:* #) #x7FFF5FBFF5B0>
   #:G4926: #<A Foreign Pointer #x7FFF830E7D48>
   CCL::ARG0: #<NS-EVENT NSEvent: type=KeyDown loc=(0,962) time=600541.2 flags=0x100 win=0x0 winNum=9780 ctxt=0x0 chars="
" unmodchars="
" repeat=0 keyCode=36 (#xB41D6E0)>



 (442D98) : 22 (%CALL-NEXT-OBJC-METHOD #<LISP-APPLICATION <LispApplication: 0x1cb4d0> (#x1CB4D0)> #<OBJC:OBJC-CLASS GUI::LISP-APPLICATION (#x134330)> #<A Foreign Pointer #x7FFF830E7D48> (:VOID :ID) #<NS-EVENT NSEvent: type=KeyDown loc=(0,962) time=600541.2 flags=0x100 win=0x0 winNum=9780 ctxt=0x0 chars="
" unmodchars="
" repeat=0 keyCode=36 (#xB41D6E0)>) 773
  (CCL::SELF CLASS CCL::SELECTOR CCL::SIG &REST CCL::ARGS)
   CCL::SELF: #<LISP-APPLICATION <LispApplication: 0x1cb4d0> (#x1CB4D0)>
   CLASS: #<OBJC:OBJC-CLASS GUI::LISP-APPLICATION (#x134330)>
   CCL::SELECTOR: #<A Foreign Pointer #x7FFF830E7D48>
   CCL::SIG: (:VOID :ID)
   CCL::ARGS: (#<NS-EVENT NSEvent: type=KeyDown loc=(0,962) time=600541.2 flags=0x100 win=0x0 winNum=9780 ctxt=0x0 chars="
" unmodchars="
" repeat=0 keyCode=36 (#xB41D6E0)>)

  CCL::S: #<A Foreign Pointer [stack-allocated] (:* #) #x7FFF5FBFF5B0>
  CCL::SIGINFO: #S(CCL::OBJC-METHOD-SIGNATURE-INFO :TYPE-SIGNATURE (:VOID :ID) :FUNCTION #<Anonymous Function #x3000414286FF> ...)
  FUNCTION: #<Anonymous Function #x30004142838F>

 (442DF8) : 23 (FUNCALL #'#<GUI::|-[LispApplication sendEvent:]|> 17591849975520) 965
  (#:G5747)
   #:G5747: 17591849975520

  #:G5762: #<A Foreign Pointer [stack-allocated] #x7FFF5FBFF700>
  #:G5748: #<A Foreign Pointer [stack-allocated] #x7FFF5FBFF700>
  #:COMPILER-VAR: (NIL)
  #:G5752: #<COMPILED-LEXICAL-CLOSURE (:INTERNAL GUI::|-[LispApplication sendEvent:]|) #x493D6F>
  #:G5763: (CONDITION #<COMPILED-LEXICAL-CLOSURE # #x493D6F>)
  CCL::%HANDLERS%: ((CONDITION #))
  GUI::SELF: #<LISP-APPLICATION <LispApplication: 0x1cb4d0> (#x1CB4D0)>
  GUI::E: #<NS-EVENT NSEvent: type=KeyDown loc=(0,962) time=600541.2 flags=0x100 win=0x0 winNum=9780 ctxt=0x0 chars="
" unmodchars="
" repeat=0 keyCode=36 (#xB41D6E0)>
  CCL::ARGS: (#<NS-EVENT NSEvent: type=KeyDown loc=(0,962) time=600541.2 flags=0x100 win=0x0 winNum=9780 ctxt=0x0 chars="
" unmodchars="
" repeat=0 keyCode=36 (#xB41D6E0)>)

 (442E68) : 24 (%PASCAL-FUNCTIONS% 15 17591849975520) 365
  (CCL::INDEX CCL::ARGS-PTR-FIXNUM)
   CCL::INDEX: 15
   CCL::ARGS-PTR-FIXNUM: 17591849975520

  CCL::LISP-FUNCTION: #<Compiled-function GUI::|-[LispApplication sendEvent:]| (Non-Global)  #x300041474DAF>
  WITHOUT-INTERRUPTS: NIL
  CCL::*CALLBACK-TRACE-P*: NIL

 (442F28) : 25 (FUNCALL #'#<Anonymous Function #x30004138379F> #<LISP-APPLICATION <LispApplication: 0x1cb4d0> (#x1CB4D0)> #S(CCL::OBJC-SELECTOR :NAME "run" :%SEL #<A Foreign Pointer #x7FFF8319ED68>)) 173
  (#:G3175 #:G3176)
   #:G3175: #<LISP-APPLICATION <LispApplication: 0x1cb4d0> (#x1CB4D0)>
   #:G3176: #S(CCL::OBJC-SELECTOR :NAME "run" :%SEL #<A Foreign Pointer #x7FFF8319ED68>)



 (442F48) : 26 (FUNCALL #'#<(:INTERNAL CCL::SEND-UNAMBIGUOUS-MESSAGE (SHARED-INITIALIZE :AFTER (CCL::OBJC-DISPATCH-FUNCTION T)))> #<LISP-APPLICATION <LispApplication: 0x1cb4d0> (#x1CB4D0)>) 485
  (CCL::RECEIVER &REST CCL::ARGS)
   CCL::RECEIVER: #<LISP-APPLICATION <LispApplication: 0x1cb4d0> (#x1CB4D0)>
   CCL::ARGS: NIL

  CCL::SELECTOR: #S(CCL::OBJC-SELECTOR :NAME "run" :%SEL #<A Foreign Pointer #x7FFF8319ED68>)
  FUNCTION: #<Anonymous Function #x30004138379F>

 (442F88) : 27 (EVENT-LOOP NIL) 989
  (&OPTIONAL GUI::END-TEST)
   GUI::END-TEST: NIL

  GUI::APP: #<LISP-APPLICATION <LispApplication: 0x1cb4d0> (#x1CB4D0)>
  GUI::THREAD: #<APPKIT-PROCESS Initial(0) [Active] #x3000404C3F3D>
  #:ABORT: #<RESTART ABORT #x493F3D>
  #:G7834: (#<RESTART ABORT #x493F3D>)
  CCL::%RESTARTS%: ((#<# # #x493F3D>))

Change History (5)

comment:1 Changed 10 years ago by rongarret

  • Priority changed from major to normal

Upon reflection, this is not really serious enough to call "major" so I'm bumping the priority back down to "normal".

comment:2 Changed 10 years ago by gb

  • Owner set to rme

This seems to be the same problem described in http://clozure.com/pipermail/openmcl-devel/2009-August/010204.html ; it's helpful both to have it in Trac and to have what seems to be a way of reproducing it. Thanks.

comment:3 Changed 10 years ago by rme

  • Status changed from new to assigned

comment:4 Changed 10 years ago by rme

I think r12696 should fix this.

comment:5 Changed 10 years ago by rme

  • Resolution set to fixed
  • Status changed from assigned to closed
Note: See TracTickets for help on using tickets.