Opened 10 years ago

Closed 10 years ago

#560 closed defect (fixed)

Return doesn't self-insert in listener

Reported by: rongarret Owned by:
Priority: minor Milestone:
Component: IDE Version: 1.3
Keywords: Cc:

Description

There have been some changes recently to the behavior of the RETURN key in the IDE. By and large these changes have been improvements, but there is a small lingering bug: when RETURN is pressed with the cursor at the end of a listener buffer and there's a form to evaluate, the return character does not self-insert. As a result, if you PRINC something instead of PRINTing it, it ends up on the same line as the form being evaluated, which is a little weird. The problem is particularly evident when doing an apropos:

Welcome to Clozure Common Lisp Version 1.4-dev  (DarwinX8664)!
? (apropos :foo) HI::FOO
GUI::FOO
CCL::FOO
    :FOO,  Value: :FOO
? 

Change History (1)

comment:1 Changed 10 years ago by rme

  • Resolution set to fixed
  • Status changed from new to closed

should be fixed by r12428

Note: See TracTickets for help on using tickets.