Opened 10 years ago

Closed 10 years ago

#553 closed defect (invalid)

Error on (require "COCOA-APPLICATION")

Reported by: binghe Owned by:
Priority: major Milestone: Clozure CL 1.4
Component: IDE Version: trunk
Keywords: cocoa application Cc:

Description

Current CCL trunk cannot dump standalone CCL bundle (COCOA-APPLICATION), and command (require "COCOA-APPLICATION") give me following error output on latest CCL trunk (darwinx86):

Saving application to /Users/binghe/Lisp/ccl/trunk/Clozure CL64.app/

> Error: No such file or directory : "fH"
> While executing: OPEN-DUMPLISP-FILE, in process listener(1).
> Type cmd-. to abort, cmd-\ for a list of available restarts.
> Type :? for other options.

1 > :b
 (6A5550) : 0 (OPEN-DUMPLISP-FILE #P"ccl:Clozure CL64.app;Contents;MacOS;dx86cl64" :MODE 420 :PREPEND-KERNEL T) 373
 (6A55B0) : 1 (SAVE-APPLICATION #P"ccl:Clozure CL64.app;Contents;MacOS;dx86cl64" :PREPEND-KERNEL T :APPLICATION-CLASS GUI::COCOA-APPLICATION) 557
 (6A5678) : 2 (CALL-CHECK-REGS BUILD-IDE "ccl:Clozure CL64.app;") 229
 (6A56B0) : 3 (FUNCALL #'#<(:INTERNAL WITH-COMPILATION-UNIT-BODY LOAD-FROM-STREAM)>) 773
 (6A5740) : 4 (CALL-WITH-COMPILATION-UNIT #<COMPILED-LEXICAL-CLOSURE (:INTERNAL WITH-COMPILATION-UNIT-BODY LOAD-FROM-STREAM) #x7B615F> :OVERRIDE NIL) 197
 (6A5788) : 5 (LOAD-FROM-STREAM #<BASIC-FILE-CHARACTER-INPUT-STREAM ("/Users/binghe/Lisp/ccl/trunk/cocoa-ide/cocoa-application.lisp"/4 ISO-8859-1) #x300040F447AD> NIL) 389
 (6A57C8) : 6 (%LOAD #P"/Users/binghe/Lisp/ccl/trunk/cocoa-ide/cocoa-application.lisp" NIL NIL :ERROR :DEFAULT) 3573
 (6A5918) : 7 (LOAD #P"/Users/binghe/Lisp/ccl/trunk/cocoa-ide/cocoa-application.lisp" :VERBOSE NIL :PRINT NIL :IF-DOES-NOT-EXIST :ERROR :EXTERNAL-FORMAT :DEFAULT) 1029
 (6A59B8) : 8 (MODULE-PROVIDE-SEARCH-PATH "COCOA-APPLICATION") 197
 (6A59F8) : 9 (SOME-XX-ONE 0 NIL #<COMPILED-LEXICAL-CLOSURE (:INTERNAL REQUIRE) #x7B643F> (MODULE-PROVIDE-SEARCH-PATH MODULE-PROVIDE-ASDF)) 613
 (6A5A50) : 10 (REQUIRE "COCOA-APPLICATION" NIL) 789
 (6A5AB8) : 11 (CALL-CHECK-REGS REQUIRE "COCOA-APPLICATION") 229
 (6A5AF0) : 12 (TOPLEVEL-EVAL (REQUIRE "COCOA-APPLICATION") NIL) 733
 (6A5B90) : 13 (READ-LOOP :INPUT-STREAM #<SYNONYM-STREAM to *TERMINAL-IO* #x300040F405FD> :OUTPUT-STREAM #<SYNONYM-STREAM to *TERMINAL-IO* #x300040F4049D> :BREAK-LEVEL 0 :PROMPT-FUNCTION #<Compiled-function (:INTERNAL READ-LOOP) (Non-Global)  #x30004054236F>) 2053
 (6A5DD0) : 14 (TOPLEVEL-LOOP) 109
 (6A5E00) : 15 (FUNCALL #'#<(:INTERNAL (TOPLEVEL-FUNCTION (LISP-DEVELOPMENT-SYSTEM T)))>) 117
 (6A5E20) : 16 (FUNCALL #'#<(:INTERNAL MAKE-MCL-LISTENER-PROCESS)>) 645
 (6A5EB8) : 17 (RUN-PROCESS-INITIAL-FORM #<TTY-LISTENER listener(1) [Active] #x300040F3F41D> (#<COMPILED-LEXICAL-CLOSURE # #x300040F3EF5F>)) 717
 (6A5F48) : 18 (FUNCALL #'#<(:INTERNAL (%PROCESS-PRESET-INTERNAL (PROCESS)))> #<TTY-LISTENER listener(1) [Active] #x300040F3F41D> (#<COMPILED-LEXICAL-CLOSURE # #x300040F3EF5F>)) 389
 (6A5F98) : 19 (FUNCALL #'#<(:INTERNAL THREAD-MAKE-STARTUP-FUNCTION)>) 301

In my OS environment (Mac OS X 10.5.7), CCL 1.3 is good when trying to do the same thing. And (require "COCOA") always works well on both CCL 1.3 and trunk.

Change History (3)

comment:1 Changed 10 years ago by gb

I can't reproduce this; I can't see the contents of the top few stack frames in your environment either, so I can't begin to guess where the string "fH" is coming from.

What does:

? (ccl::kernel-path)

return in the environment where you get this error ?

If it returns something other than a string naming the full pathname of the running lisp kernel, that may be because the kernel itself needs to be recompiled.

There isn't some general problem here; I don't know what's causing the behavior that you're seeing.

comment:2 Changed 10 years ago by binghe

(ccl::kernel-path) just returns "fH" here:

Welcome to Clozure Common Lisp Version 1.4-dev-r12371  (DarwinX8664)!
? (ccl::kernel-path)
"fH"

But you're right. After rebuild lisp-kernel, the return value of (ccl::kernel-path) go back to normal:

? (ccl::kernel-path)
"/Users/binghe/Lisp/ccl/trunk/dx86cl64"

I don't know why this happens, but now I can dump the standalone CCL bundle correctly. Thank you!

comment:3 Changed 10 years ago by gb

  • Resolution set to invalid
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.