Opened 10 years ago

Last modified 4 years ago

#536 reopened defect

Entering a breakloop by evaluating a form in a SLIME REPL wedges the SLIME REPL

Reported by: mikel Owned by:
Priority: normal Milestone: Cocoa IDE v?
Component: IDE Version: 1.3
Keywords: Cc:

Description

Start the IDE and obtain a SLIME connection to it. (Any working means of obtaining a SLIME connection is fine. You can use the swank-listener feature in recent IDEs, or simply start up the IDE, load and start swank by hand, and then connect using M-x slime-connect.)

Make sure the SLIME REPL is started (recent releases of SLIME don't necessarily start the REPL by default).

From the SLIME REPL, evaluate the following form:

(gui::execute-in-gui

(lambda ()

(break)))

The results are initially as expected: you should see a working breakloop in the SLIME REPL. The problem occurs when using Q to tell the SLIME REPL to quit from the breakloop. After the exit from the breakloop, the SLIME REPL no longer responds to input.

A user who sees this issue can work around it by using M-x slime-disconnect, followed by M-x slime-connect to obtain a working SLIME REPL again.

Here are a few related clues:

  1. If you eval the above form from a SLIME buffer other than the REPL, you will not see the problem. In that case, everything works as expected.
  1. If you eval the above form from the an IDE Listener window, you will likewise not see the problem. Again, everything works as expected.
  1. If you induce a break on the event thread using code called from Cocoa UI widgets, you will not see the problem.
  1. gb reports that he believes that using :Q to quit a breakloop in AltConsole? "sails off into the ozone", and probably needs a restart wrapped around it. If so, this may be the cause of the problem we observe in the SLIME REPL. In that case, I don't know why the other cases don't exhibit the problem (perhaps they happen to have handy restarts wrapped around them).

Change History (2)

comment:1 Changed 4 years ago by rme

  • Resolution set to fixed
  • Status changed from new to closed

(In [16639]) Replace scale-exponent with accurate-scaled-exponent, borrowed from CMUCL.

Closes ticket:536 and ticket:1186.

comment:2 Changed 4 years ago by rme

  • Resolution fixed deleted
  • Status changed from closed to reopened

Closed by mistake.

Note: See TracTickets for help on using tickets.