Opened 10 years ago

Closed 10 years ago

#520 closed defect (fixed)

Execute-all doesn't respect current state of buffer

Reported by: rongarret Owned by: rme
Priority: normal Milestone:
Component: IDE Version: trunk
Keywords: Cc:

Description

If a saved file has been edited then execute-all appears to execute the saved version, not the version in the buffer, e.g:

Put (print 123) into a buffer.

Save it.

Change it to (print 456) but don't save.

Execute all.

Result will be 123, not 456.

Not sure if this is by design, but it's not the behavior I intuitively expect.

Change History (2)

comment:1 Changed 10 years ago by rme

  • Owner set to rme
  • Status changed from new to assigned

comment:2 Changed 10 years ago by rme

  • Resolution set to fixed
  • Status changed from assigned to closed

r12168 should correct this.

Note: See TracTickets for help on using tickets.