Opened 10 years ago

Closed 10 years ago

#517 closed defect (fixed)

error in CCL-DIRECTORY or USER-HOMEDIR-PATHNAME

Reported by: hrapof Owned by: gb
Priority: normal Milestone:
Component: project hosting Version: 1.3
Keywords: Cc:

Description

First of all, there is a thread on lispforum about CCL CGI woes: http://www.lispforum.com/viewtopic.php?f=2&t=342

Not quite related, but in the same vein, when Clozure CL CGI is executed under certain configurations of IIS on Windows, it dies with the following error:

Error: value NIL is not of the expected type (OR STRING PATHNAME STREAM). > While executing: PATHNAME-DIRECTORY, in process Initial(0). > Type :GO to continue, :POP to abort, :R for a list of available restarts. > If continued: Skip (possibly crucial) startup function CCL::INIT-LOGICAL-DIRECTORIES. > Type :? for other options. 1 > > Error: Unbound variable: -----------------------------7D9140680DE0 > While executing: CCL::TOPLEVEL-EVAL, in process Initial(0). > Type :GO to continue, :POP to abort, :R for a list of available restarts. > If continued: Retry getting the value of -----------------------------7D9140680DE0. > Type :? for other options. 2 > > Error: Unbound variable: ------7D9140680DE0 > While executing: CCL::TOPLEVEL-EVAL, in process Initial(0). > Type :GO to continue, :POP to abort, :R for a list of available restarts. > If continued: Retry getting the value of ------7D9140680DE0. > Type :? for other options. 3 > > Error: Reader error on #, within "position: form-data;": > Reference to unknown package "TENT-DISPOSITION". > While executing: CCL::SIGNAL-READER-ERROR, in process Initial(0). > Type :POP to abort, :R for a list of available restarts. > Type :? for other options. 4 > > Error: Unbound variable: FORM-DATA > While executing: CCL::TOPLEVEL-EVAL, in process Initial(0). > Type :GO to continue, :POP to abort, :R for a list of available restarts. > If continued: Retry getting the value of FORM-DATA. > Type :? for other options. 5 > "thefile" 5 > > Error: Reader error on #, within "ent-Type: image/pjpe": > Reference to unknown package "CONTENT-TYPE". > While executing: CCL::SIGNAL-READER-ERROR, in process Initial(0). > Type :POP to abort, :R for a list of available restarts. > Type :? for other options. 6 > > Error: Unbound variable: JFIF > While executing: CCL::TOPLEVEL-EVAL, in process Initial(0).

Commenting the contents of INIT-LOGICAL-DIRECTORIES out solves the problem.

Change History (2)

comment:1 Changed 10 years ago by gb

  • Status changed from new to assigned

somewhere around r12129 in the trunk are some changes that're intended to ensure that the lisp's notion of the pathname to the current image is fully qualified; if the CCL_DEFAULT-DIRECTORY environment variable isn't set, the CCL directory is assumed to be the directory that contains the heap image.

(There are some earlier related changes in the trunk that try to ensure that the startup code uses the "Unicode" version of command-line arguments on Windows, which may also help with this sort of thing.)

I don't know for sure if these changes fix this problem; if anyone who knows how to reproduce it can try to do so with the current trunk sources, it'd be very helpful to know if there's still a problem there.

comment:2 Changed 10 years ago by rme

  • Resolution set to fixed
  • Status changed from assigned to closed

I'm going to close this; please re-open it if there's still a problem.

Note: See TracTickets for help on using tickets.