Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#394 closed enhancement (invalid)

Please consider enabling EGC by default

Reported by: jch Owned by: gb
Priority: minor Milestone:
Component: Runtime (threads, GC) Version:
Keywords: Cc:

Description

On Linux/x86_64, I've found CCL to perform slightly better with EGC enabled, even for batch jobs. Obviously, for interactive tasks EGC appears to be a big win (avoiding the 0.7 second pauses that I get with the ordinary GC).

Please consider enabling the EGC by default, at least on Linux.

Change History (2)

comment:1 Changed 11 years ago by gb

  • Resolution set to invalid
  • Status changed from new to closed

The EGC's been enabled by default in CCL/OpenMCL for several years. Some exceptions:

  • there's a build-time flag that can be set in the Makefile (-DDISABLE_EGC) that keeps it from being enabled; this can be useful early in a port's development (when there are often so many other bugs that chasing EGC bugs is pointless.)
  • a few weeks ago, I made a change in the trunk (r11501) that was intended to allow [E]GC options to persist across SAVE-APPLICATION. I botched it, and the effect was to always disable the EGC on startup. This was fixed (r11531), though I think that the last set of images checked into the trunk were affected. (Doing an "svn update"/(rebuild-ccl :full t) should fix things.)

Unless you're using a development branch or a trunk image built a few weeks ago, the EGC should be enabled by default.

comment:2 Changed 11 years ago by gb

Um, the gc-state-saving changes were actually un-botched in r11551 (not r11531).

Note: See TracTickets for help on using tickets.