Opened 11 years ago

Closed 11 years ago

#381 closed defect (fixed)

hang when displaying NSRect record

Reported by: rme Owned by: gb
Priority: normal Milestone:
Component: IDE Version: trunk
Keywords: Cc:

Description

Start IDE with (require 'cocoa). (Either 64- or 32-bit x86).

Into a listener, type:

(defvar *junk* (ns:make-ns-rect 0 0 100 100))
*junk*

The IDE will hang.

Change History (4)

comment:1 Changed 11 years ago by gb

  • Owner changed from gz to gb
  • Status changed from new to assigned

I've been unable to reproduce this.

comment:2 Changed 11 years ago by gb

Spoke too soon; it now seems to be looping in the splay-tree code.

comment:3 Changed 11 years ago by gb

I was only able to reproduce this intermittently.

Does r11426 seem to fix it ?

comment:4 Changed 11 years ago by rme

  • Resolution set to fixed
  • Status changed from assigned to closed

This seems not to happen any more (in an r11427 lisp).

Note: See TracTickets for help on using tickets.