Opened 11 years ago

Closed 10 years ago

#311 closed defect (fixed)

can't execute-selection that ends in a comment

Reported by: gz Owned by: gz
Priority: major Milestone: Cocoa IDE v1
Component: IDE Version:
Keywords: Cc:

Description

From openmcl-devel:

At 6/10/2008 01:54 AM, Rich Sutton wrote: in the ide, bring up a listener. then make a buffer that ends with a comment, say a new buffer with just a ; in it. finally, select the contents of the buffer and invoke execute-selection. your listener will disappear. otherwise appears to be harmless. applies to multi-line comments too -- i ran into this because i had a bunch of test code commented out at the end of some file i was working on.

Change History (3)

comment:1 Changed 11 years ago by gb

I believe that what happens is that the selection stream gets an EOF and the REPL asks whether or not EOF is "transient" on the input stream (as it can be on a TTY but generally isn't on other kinds of communication devices.) When we used PTYs in Cocoa listeners, that used to work (i.e., not terminate the REPL.)

If the transient-eof idea makes sense, it should probably be a method on the stream (that fd-based streams implement by looking at the fd's file type.)

comment:2 Changed 11 years ago by jaj

  • Milestone set to Cocoa IDE v1

Easily reproduced.

comment:3 Changed 10 years ago by gb

  • Resolution set to fixed
  • Status changed from new to closed

I believe that this is just a general case where unexpected EOF caused an IDE listener to exit and that it's fixed in the trunk as of r12125 (actually a bit earlier.)

Note: See TracTickets for help on using tickets.