Opened 12 years ago

Closed 12 years ago

#29 closed defect (worksforme)

Can't Finder open .Lisp files by dragging their icons to the Dock

Reported by: alms Owned by: gb
Priority: major Milestone:
Component: IDE Version: 1.1
Keywords: Cc:

Description

With the IDE running, I can open .lisp files from File/Open?... menu. However, if I try to open them by dragging them from the Finder onto the IDE's icon in the dock, I get the message, "You cannot open the application "OpenMCL" because it is not supported on this architecture. I'm running on Intel/Leopard?. Same thing happens for text files.

Change History (4)

comment:1 Changed 12 years ago by gb

  • Status changed from new to assigned
  • Summary changed from Can't Finder open .Lisp files to Can't Finder open .Lisp files by dragging their icons to the Dock

comment:2 Changed 12 years ago by gb

What icons do these lisp files have in the finder ? I.e., is it the aqua-colored lambda, or something else ?

comment:3 Changed 12 years ago by gb

I just tried it (didn't even know that you could open files by dragging them to the dock icon) and it worked as expected.

I tend to think that you may have some other application installed that claims to own .lisp files; perhaps that other application targets another architecture.

If that's the case (or to see if it is or not), select a .lisp file in the Finder and do "Get Info"; see what application (if any) is associated with .lisp files. If it's not OpenMCL, change it (and check the box which makes this true of all .lisp files.)

If that's what the issue is, this is not an OpenMCL bug. If it isn't ... I have no idea.

comment:4 Changed 12 years ago by alms

  • Resolution set to worksforme
  • Status changed from assigned to closed

Hmmm... This now works for me.

This may have had something to do with the fact that I made a backup copy of OpenMCL.app when I was mucking with the nib files. The copy showed up with the lambda icon and a ghostbusters "no" symbol over it (OS X's way of indicating an app that can't be run). But in any case, I can no longer reproduce this bug, so let's call it closed.

For the record, I was getting the same behavior when double-clicking .lisp files, i.e. it said they couldn't be opened with exactly the same message.

Note: See TracTickets for help on using tickets.