Opened 12 years ago

Closed 12 years ago

#237 closed defect (fixed)

IDE wedges trying to navigate within string

Reported by: gz Owned by: gz
Priority: major Milestone:
Component: IDE Version:
Keywords: Cc:

Description

In a new buffer, enter

(foo "bar

then place the insertion point after the quotes and press, e.g., c-m-f. IDE will wedge and has to be killed.

I think the problem is that generally, hemlock code isn't prepared to navigate inside strings (valid-spot is nil), but much of the time it doesn't actually check for it so in some cases it just goes into infinite loops.

Change History (1)

comment:1 Changed 12 years ago by gz

  • Resolution set to fixed
  • Status changed from new to closed

Fixed in r8464

Note: See TracTickets for help on using tickets.