Opened 11 years ago

Closed 10 years ago

#222 closed defect (worksforme)

Window-switching causes errors in hemlock event-handling (event-ide branch)

Reported by: mikel Owned by: gz
Priority: major Milestone:
Component: IDE Version: unspecific
Keywords: event-ide branch Cc:

Description

In a Clozure CL.app built from the event-ide branch:

  1. Open a file of Lisp text. Select a range of text
  2. Switch to a Listener window
  3. Eval uate some form that causes a backtrace
  4. Switch back to the editor window

At this point, if the problem has manifested, clicking in the buffer fails to cause the window to update its selection correctly. Typing in the buffer *may* cause the display to return to normal, or it may display a Hemlock error dialog (the "sky is falling" dialog). Generally, some combination of inserting and deleting text seems to eventually cause the window display and event-handling to return to normal.

Change History (1)

comment:1 Changed 10 years ago by jaj

  • Resolution set to worksforme
  • Status changed from new to closed

I can't reproduce this in r11688, I'm marking it worksforme.

Note: See TracTickets for help on using tickets.