Opened 12 years ago

Closed 11 years ago

#211 closed defect (fixed)

Tilde at the end of expression causes the sky to fall

Reported by: ds Owned by: gb
Priority: major Milestone: Cocoa IDE v1
Component: IDE Version:
Keywords: Cc:

Description

(defun foo~ (x) x)

(foo~

As soon as you type a space after the last "~" above, you get my favourite error message: The sky is falling! Fred NEVER did this!

Dimitri

Change History (4)

comment:1 Changed 11 years ago by jaj

  • Milestone set to Cocoa IDE v1

Easily reproducible. Leave priority major.

comment:2 Changed 11 years ago by gb

A very simple way to reproduce this:

? (format t "FOO~ : (X)")
> Error: 
>        Unknown directive
>        "FOO~ : (X)"
>             ^

Moral: code that uses FORMAT as shorthand for WRITE-STRING should be really careful to ensure that that string doesn't contain unescaped tildes; since that's often not possible/practical, code probably shouldn't use FORMAT as shorthand for WRITE-STRING. (Or use HI::MESSAGE that way, either.)

comment:3 Changed 11 years ago by gb

  • Status changed from new to assigned

This is fixed in the trunk in r11731. The changes are trivial and localized, so it'd be easy to apply them to releases.

comment:4 Changed 11 years ago by rme

  • Resolution set to fixed
  • Status changed from assigned to closed

Ported to 1.3 in r11747.

Note: See TracTickets for help on using tickets.