Opened 12 years ago

Closed 12 years ago

#185 closed defect (fixed)

installing new snapshot makes pref pane inaccessible

Reported by: Brian Owned by: rme
Priority: minor Milestone:
Component: IDE Version:
Keywords: preferences Cc:

Description

Installing the new Clozure Common Lisp Version 1.1-r7538 snapshot on a system that had the previous snapshot operating kills the display of the preference pane. Preferences are still correctly read, but the interface is lost.

Remedy is to delete the file "com.clozure.Clozure CL.plist", but of course this also loses all preference settings.

Change History (5)

comment:1 in reply to: ↑ description Changed 12 years ago by Brian

Addendum: The "remedy" of deleting the .plist file allows the preference pane to open only once. On relaunching CCL, the preferences menu item is again disabled.

comment:2 Changed 12 years ago by rme

  • Owner changed from gb to rme
  • Status changed from new to assigned

Is there any way you can rebuild from current sources? The preferences panel has been substantially changed.

http://trac.clozure.com/openmcl/wiki/UpdatingFromSource

(By the way, are you on Tiger or Leopard? PPC or x86-64?)

comment:3 Changed 12 years ago by rme

A new CCL disk image is out, if you're interested in trying it and seeing if this problem is still there.

ftp://clozure.com/pub/testing/ClozureCL2007-12-03.dmg

comment:4 Changed 12 years ago by Brian

On my system the failure was sporadic under the 10/19 version of CCL; I haven't been able to reproduce it with the 12/03 release. (OS X 10.4.10 on PPC).

comment:5 Changed 12 years ago by rme

  • Resolution set to fixed
  • Status changed from assigned to closed

I'll assume that the problem was corrected by the new preferences panel.

If it still messes up somehow, please re-open this ticket.

Note: See TracTickets for help on using tickets.