Opened 12 years ago

Closed 12 years ago

#184 closed defect (fixed)

Sometimes the open dialog shows empty directories

Reported by: joswig Owned by: rme
Priority: major Milestone:
Component: IDE Version: 1.1
Keywords: Cc:

Description

When I do command-o in Clozure CL, I get a File Selector window. Sometimes when I double click on a directory, the directory is opened in the File selector window, but there are no contents listed. Going back to the parent and reopen the directory helps. Once the dialog has displayed the contents, later displaying the directory seems to work.

Latest CCL from CVS, Mac OS X 10.5

Change History (3)

comment:1 Changed 12 years ago by rme

  • Owner changed from gb to rme
  • Status changed from new to assigned

This is the same problem noted in ticket:172.

I'll leave this ticket open until Apple fixes the bug. (I probably should have done that with ticket:172.)

comment:2 Changed 12 years ago by joswig

I have seen one additional strage behavior:

I have a home directory called joswig. On another machine I also have a home directory called joswig. I have that directory mounted.

When I use the open file dialog, sometimes the mounted (and it is mounted, I can see it in finder windows) directory joswig has no unmount icon next to it and clicking on it shows no content. Dragging a file from that directory in the finder onto the Clozure CL icon also does not open the file.

comment:3 Changed 12 years ago by rme

  • Resolution set to fixed
  • Status changed from assigned to closed

This bug appears to be fixed in Mac OS X 10.5.2.

Note: See TracTickets for help on using tickets.