Opened 12 years ago

Closed 12 years ago

Last modified 12 years ago

#130 closed defect (worksforme)

Inspecting process info crashes the IDE

Reported by: mikel Owned by: gb
Priority: major Milestone:
Component: IDE Version:
Keywords: Cc:

Description

Steps to reproduce:

  1. Open IDE (OpenMCL or Clozure CL)
  2. Open the Processes window
  3. Double-click to open the Cocoa Inspector
  4. Browse the slots of the inspected process
  5. Click the contents of a slot to inspect it
  6. Crash!

Change History (2)

comment:1 Changed 12 years ago by rme

  • Resolution set to worksforme
  • Status changed from new to closed

Seems to be working now. Not sure what fixed it.

comment:2 Changed 12 years ago by gb

Gail changed the PRINT-OBJECT methods (or DEFSTRUCT print-functions) of some Hemlock data structures so that they'd bind ugly internal nonsense rather than error while printing, and that caused the symptom to go away.

We still have problem(s) related to handling errors in the event thread without losing track of things completely; we just don't get an unhandled error trying to print the internals of Hemlock buffers anymore. See ticket:139 and ticket:145 for other cases of this.

(We -should- have just said #<error printing REGION> before Gail's change and gone on to print the next thing and eventually gotten the next event; I think that the event thread was actually sitting in a break loop, wondering why it kept getting EOF from whoever was on the other end of the connection ...)

Note: See TracTickets for help on using tickets.