Opened 6 years ago

Last modified 6 years ago

#1154 reopened defect

Update the Search Files tool

Reported by: xach Owned by: xach
Priority: normal Milestone:
Component: IDE Version: trunk
Keywords: Cc:

Description

From alms:

There are a few features in Opusmodus that would be useful to have in the CCL IDE:

...

  1. The Search Files tool. (cleaner implementation than the one currently in the CCL IDE).

Change History (10)

comment:1 Changed 6 years ago by alms

  • Owner set to xach

comment:2 Changed 6 years ago by xach

Hmm, I tried to take a look at Search Files in OpusModus?, and whenever I select its menu item under "Develop > Tools > Search Files...", in the terminal I get:

  ;;;
  ;;; #<APPKIT-PROCESS Initial(0) [Reset] #x3020000B002D> requires access to Shared Terminal Input
  ;;; Type (:y 0) to yield control to this thread.
  ;;;
  (:y 0)


  ;;;
  ;;; Shared Terminal Input is now owned by #<APPKIT-PROCESS Initial(0) [Reset] #x3020000B002D>
  ;;;

  > Type :GO to continue, :POP to abort, :R for a list of available restarts.
  > If continued: Try calling it again
  > Type :? for other options.
  1 > :pop

  ;;;
  ;;;control of Shared Terminal Input restored to #<TTY-LISTENER listener(1) [Active] #x3020003584DD>
  ;;;
  ? 2014-02-17 09:43:05.579 dx86cl64[97846:d07] An uncaught exception was raised
  2014-02-17 09:43:05.579 dx86cl64[97846:d07] encapsulated-throw
  2014-02-17 09:43:05.581 dx86cl64[97846:d07] (
	  0   CoreFoundation                      0x00007fff8dc3c41c __exceptionPreprocess + 172
	  1   libobjc.A.dylib                     0x00007fff8b2d8e75 objc_exception_throw + 43
	  2   AppKit                              0x00007fff9192e3d0 -[NSApplication sendAction:to:from:] + 327
	  3   AppKit                              0x00007fff91949348 -[NSMenuItem _corePerformAction] + 394
	  4   AppKit                              0x00007fff91949084 -[NSCarbonMenuImpl performActionWithHighlightingForItemAtIndex:] + 117
	  5   AppKit                              0x00007fff919984dd -[NSMenu _internalPerformActionForItemAtIndex:] + 35
	  6   AppKit                              0x00007fff91998359 -[NSCarbonMenuImpl _carbonCommandProcessEvent:handlerCallRef:] + 104
	  7   AppKit                              0x00007fff9193f176 NSSLMMenuEventHandler + 716
	  8   HIToolbox                           0x00007fff984756d4 _ZL23DispatchEventToHandlersP14EventTargetRecP14OpaqueEventRefP14HandlerCallRec + 892
	  9   HIToolbox                           0x00007fff98474c87 _ZL30SendEventToEventTargetInternalP14OpaqueEventRefP20OpaqueEventTargetRefP14HandlerCallRec + 385
	  10  HIToolbox                           0x00007fff98488d90 SendEventToEventTarget + 40
	  11  HIToolbox                           0x00007fff984bea30 _ZL18SendHICommandEventjPK9HICommandjjhPKvP20OpaqueEventTargetRefS5_PP14OpaqueEventRef + 420
	  12  HIToolbox                           0x00007fff984f1618 SendMenuCommandWithContextAndModifiers + 59
	  13  HIToolbox                           0x00007fff984f15c4 SendMenuItemSelectedEvent + 178
	  14  HIToolbox                           0x00007fff984f14a5 _ZL19FinishMenuSelectionP13SelectionDataP10MenuResultS2_ + 94
	  15  HIToolbox                           0x00007fff984f9425 _ZL14MenuSelectCoreP8MenuData5PointdjPP13OpaqueMenuRefPt + 718
	  16  HIToolbox                           0x00007fff984f9051 _HandleMenuSelection2 + 446
	  17  AppKit                              0x00007fff918b179c _NSHandleCarbonMenuEvent + 284
	  18  AppKit                              0x00007fff9171056e _DPSNextEvent + 2170
	  19  AppKit                              0x00007fff9170f8db -[NSApplication nextEventMatchingMask:untilDate:inMode:dequeue:] + 122
	  20  AppKit                              0x00007fff917039cc -[NSApplication run] + 553
	  21  ccl                                 0x000000000001b0bb ffcall_return + 0
  )

Should that be submitted as an OM issue, or is it something broken on my end?

comment:3 Changed 6 years ago by xach

  • Status changed from new to assigned

Per rme, that's not the normal Search Files. The normal Search Files is part of the left pane of the application, under the magnifying glass icon. The code for it is in ui/search-files.lisp.

comment:4 Changed 6 years ago by xach

This has been implemented by r16038, r16039, and r16040.

comment:5 Changed 6 years ago by xach

  • Resolution set to fixed
  • Status changed from assigned to closed

comment:6 Changed 6 years ago by p2

  • Type changed from enhancement to defect

All new download of 1.10-dev-r16040M-trunk (DarwinX8664) then (require :cocoa-application) causes:

;Compiling "/ccl/ccltrunk/cocoa-ide/search-files.lisp"... Read error between positions 92 and 373 in /ccl/ccltrunk2/cocoa-ide/search-files.lisp.

Error: Reader error: No external symbol named "NS-TABLE-CELL-VIEW" in package #<Package "NS"> . While executing: CCL::%PARSE-TOKEN, in process listener(1).

comment:7 Changed 6 years ago by xach

  • Resolution fixed deleted
  • Status changed from closed to reopened

I'll check it out.

comment:8 follow-up: Changed 6 years ago by xach

I can't reproduce locally - after a fresh checkout, I am able to rebuild ccl and (require :cocoa-application) without issue.

What version of OS X are you using?

comment:9 Changed 6 years ago by rme

Support for view-based NSTableViews, NSOutlineViews, and supporting classes (such as NSTableCellView) were introduced in Lion.

We could probably go back to using a cell-based NSOutlineView, but the real question is whether we try to keep the IDE running on 10.6 Snow Leopard systems, and if so, for how long?

comment:10 in reply to: ↑ 8 Changed 6 years ago by p2

Replying to xach:

I can't reproduce locally - after a fresh checkout, I am able to rebuild ccl and (require :cocoa-application) without issue.

What version of OS X are you using?

As RME indicated, I was using 10.6.8 Sounds as if SL can't keep up with the trunk.

Note: See TracTickets for help on using tickets.