Opened 8 years ago

Last modified 5 years ago

#1142 assigned defect

ccl crashes after calling (quit)

Reported by: anta40 Owned by: gb
Priority: normal Milestone:
Component: Compiler Version: trunk
Keywords: Cc:

Description (last modified by gb)

Steps to reproduce (using cygwin):

  1. Grab the latest revision (16010)
    cd /cygdrive/c/ccl
    svn update
    
  2. Rebuild the kernel:
    cd lisp-kernel/win32
    make
    
  1. Rebuild ccl
    cd ../..
    ./wx86cl
    (ccl:rebuild-ccl :clean t)
    ..
    ..
    ..
    ;Loading #P"C:/ccl/level-0/l0-pred.wx32fsl"...
    ;Loading #P"C:/ccl/level-0/l0-symbol.wx32fsl"...
    ;Loading #P"C:/ccl/level-0/l0-utils.wx32fsl"...
    ;Loading #P"C:/ccl/level-0/nfasload.wx32fsl"...
    ;Wrote bootstrapping image: #P"C:/ccl/wx86-boot32.image"
    ;Wrote heap image: #P"C:/ccl/wx86cl.image"
    NIL
    
  1. Call (quit)
    %eax = 0x000000c4
    %ecx = 0x01bcf20c
    %edx = 0x0000ee00
    %ebx = 0x7ffdee88
    %esp = 0x01bcf524
    %ebp = 0x000253d6
    %esi = 0x01bcf9e0
    %edi = 0x00000000
    %eip = 0x7ffdfec7
    %eflags = 0x00010693
    
    %cs = 0x001b
    %ds = 0x0023
    %ss = 0x0023
    %es = 0x0023
    %fs = 0x003b
    %gs = 0x0000
    Exception on foreign stack
    
    Exception occurred while executing foreign code
    

Change History (6)

comment:1 Changed 8 years ago by gb

  • Description modified (diff)

comment:2 Changed 8 years ago by gb

  • Owner set to gb
  • Status changed from new to assigned

At first glance, doing

cd ccl
svn revert wx86cl.exe

(e.g, restoring the wx86cl.exe binary to the version in svn) seems to avoid the problem.

As far as I can tell, the only difference between that binary and one built from source is that the latter

  1. contains a fix for an obscure bug
  2. is built with a more recent version of the Cygwin toolchain.

I'm much more suspicious of (2) than of (1); I don't know whether it's an outright bug in the Cygwin/mingw tools, a bug in CCL, or something else.

comment:3 Changed 7 years ago by loic

Hello,

I have tried on Vista 32 bits, with cygwin version 2.831 (32 bits), and everything work well.

Maybe like gb said, it the version of cygwin, what is your version ?

comment:4 Changed 7 years ago by gb

I tried upgrading my 32-bit cygwin intallation to see if the problem had been fixed.

As far as I could tell, updated versions of the toolchain weren't offered during the upgrade process, but there was a newer version of the cygwin dll itself.

After upgrading cygwin, I di: {{{ does $ cd ccl/lisp-kernel/win32 $ make clean $ mke }}}

to rebuild the CCL kernel; I don't know if this steps For whatever reason, I haven't been able to reproduce the problem (e.g., QUIT does so and does so quietly.)

I'm a little hesitant to proclaim this fixed (if it is, I'm not sure what the necessary steps are). but it's not clear that any of this has anything to do with CCL either.

comment:5 Changed 7 years ago by loic

I didn't see that is was specific to a 16010 revision. I found this in /branches/acode-rewrite/source/ I don't know, what this branch is it ? maybe for test ?

So I have downloaded, I can compile, but I don't have image to test.

My idea was to try to reproduce with the revision 16010 the bug with my actual cygwin to see if that happen.

comment:6 Changed 5 years ago by rme

  • Milestone Clozure CL 1.9 deleted

Milestone Clozure CL 1.9 deleted

Note: See TracTickets for help on using tickets.