Changeset 15057


Ignore:
Timestamp:
Nov 3, 2011, 12:50:08 AM (8 years ago)
Author:
rme
Message:

When loading the Objective-C bridge, complain right away if the
Mac OS X version is not at least 10.6 (that is, if the kernel
major version is not at least 10).

File:
1 edited

Legend:

Unmodified
Added
Removed
  • trunk/source/objc-bridge/objc-support.lisp

    r14821 r15057  
    22
    33(in-package "CCL")
     4
     5#+darwin-target
     6(unless (>= (parse-integer (software-version) :junk-allowed t) 10)
     7  (error "the Objective-C bridge needs at least Mac OS X 10.6"))
    48
    59(eval-when (:compile-toplevel :load-toplevel :execute)
Note: See TracChangeset for help on using the changeset viewer.