Changeset 10147


Ignore:
Timestamp:
Jul 19, 2008, 8:23:21 PM (11 years ago)
Author:
rme
Message:

Conditionalize NEED-USE-EQL-MACRO on 32-bit-target instead of
ppc32-target.

File:
1 edited

Legend:

Unmodified
Added
Removed
  • trunk/source/level-0/l0-utils.lisp

    r7624 r10147  
    7878
    7979(eval-when (:compile-toplevel :execute)
    80   #+ppc32-target
     80  #+32-bit-target
    8181  (defmacro need-use-eql-macro (key)
    8282    `(let* ((typecode (typecode ,key)))
    8383       (declare (fixnum typecode))
    84        (or (= typecode ppc32::subtag-macptr)
    85            (and (>= typecode ppc32::min-numeric-subtag)
    86                 (<= typecode ppc32::max-numeric-subtag)))))
     84       (or (= typecode target::subtag-macptr)
     85           (and (>= typecode target::min-numeric-subtag)
     86                (<= typecode target::max-numeric-subtag)))))
    8787  #+64-bit-target
    8888  (defmacro need-use-eql-macro (key)
Note: See TracChangeset for help on using the changeset viewer.