source: release/1.2/source/tools/asdf-install/loader.lisp @ 9219

Last change on this file since 9219 was 9219, checked in by gb, 11 years ago

synch from trunk

  • Property svn:eol-style set to native
  • Property svn:keywords set to Author Date Id Revision
File size: 502 bytes
Line 
1(in-package :cl-user)
2
3(eval-when (:load-toplevel)
4  (unless (find-package 'asdf)
5    (require 'asdf)))
6
7(eval-when (:load-toplevel)
8  (unless (find-package 'asdf)
9    (error "ASDF-Install requires ASDF to load"))   
10  (let ((asdf::*verbose-out* nil))
11    (require 'asdf-install)))
12
13#+sbcl
14(defun run ()
15  (handler-case
16      (apply #'asdf-install:install (cdr *posix-argv*))
17    (error (c)
18      (format *error-output* "Install failed due to error:~%  ~A~%" c)
19      (sb-ext:quit :unix-status 1))))
20
Note: See TracBrowser for help on using the repository browser.