Ticket #772 (closed defect: fixed)

Opened 3 years ago

Last modified 3 years ago

GLIBC_2.11

Reported by: heller Owned by:
Priority: normal Milestone:
Component: IDE Version: trunk
Keywords: Cc:

Description

ccl 1.6 doesn't boot on Debian Lenny. It exits with:

lx86cl: /lib/i686/cmov/libc.so.6: version `GLIBC_2.11' not found (required by lx86cl)

Yes, I know Lenny is old, but you might mention it in the Release Notes.

It also means that I no longer can rebuild ccl from trunk.

Change History

comment:1 follow-up: ↓ 2 Changed 3 years ago by rme

I built the lisp kernel binary on an Ubuntu 10.04 system. I don't know how to say "build a binary that is compatible with glibc versions greater than or equal to x".

It should work to build the lisp kernel on your own system. Just cd ccl/lisp-kernel/linuxx8632 && make.

comment:2 in reply to: ↑ 1 Changed 3 years ago by heller

Replying to rme:

It should work to build the lisp kernel on your own system. Just cd ccl/lisp-kernel/linuxx8632 && make.

Yes, that worked. Thanks.

comment:3 Changed 3 years ago by rme

  • Status changed from new to closed
  • Resolution set to fixed

I mentioned this issue in the release notes.

Note: See TracTickets for help on using tickets.