Ticket #320 (closed defect: fixed)

Opened 6 years ago

Last modified 6 years ago

DEAD-MACPTR referenced in saved currency-converter application

Reported by: gb Owned by: gz
Priority: major Milestone:
Component: IDE Version: unspecific
Keywords: trunk Cc:

Description

It was reported in  http://clozure.com/pipermail/openmcl-devel/2008-July/008420.html that a saved CurrencyConverter application (presumably built from the trunk as of roughly the date of that message) references a DEAD-MACPTR during "early application initialization".

The current 1.2 version doesn't seem to be affected by this.

Change History

comment:1 Changed 6 years ago by gb

  • Status changed from new to closed
  • Resolution set to fixed

This seems to have been caused by code which runs after ObjC class info is cleared from the objc class maps causing (per-session) class addresses to be reentered in those maps just before the image is saved (leading to a situation where REVIVE-OBJC-CLASSES tried to enter classes in those maps and choked on the presence of DEAD-MACPTRs there.)

This should be fixed in r10255 and r10256. Since the issue's a little subtle, it might be wise to have REVIVE-OBJC-CLASSES clear the class maps before doing things (just in case something else repopulates them after they've been cleared.)

Note: See TracTickets for help on using tickets.