Ticket #1125 (closed defect: duplicate)

Opened 9 months ago

Last modified 9 months ago

defining a function named nil

Reported by: bhyde Owned by:
Priority: minor Milestone:
Component: other Version: 1.9
Keywords: Cc:

Description

It's disgusting I know. I blame the bad company I hang with. One or two of whom like to defining functions on keywords. So I think "Yeah! how about NIL?"

bash-3.2$ ccl64
Welcome to Clozure Common Lisp Version 1.9-r15759  (DarwinX8664)!
? (defun nil () (print :shame-on-you))
Lisp Breakpoint
? for help
[77472] Clozure CL kernel debugger: exit
[77472] Clozure CL kernel debugger: NIL
? (funcall (symbol-function nil))

:SHAME-ON-YOU 
:SHAME-ON-YOU
1 > (ccl:quit)
bash-3.2$

Change History

comment:1 Changed 9 months ago by gb

Wait ... are you saying that the behavior here isn't having the intended deterrent effect ?

comment:2 Changed 9 months ago by bhyde

I was of the impression that the product manager specify that the kernel debugger would public shame the user by posting something to twitter?

comment:3 Changed 9 months ago by rme

This is a duplicate of ticket:613, by the way.

comment:4 Changed 9 months ago by bhyde

  • Status changed from new to closed
  • Resolution set to duplicate
Note: See TracTickets for help on using tickets.